Описание программы

Thrustmapper

Thrustmapper представляет собой программу, которая позволяет Вам запрограммировать игровой контроллер Thrustmaster. Вы также можете закрепить за кнопками управления персональные команды и перенастроить оси контроллера. Например, Вы можете запрограммировать оси контроллера так, чтобы с помощью игрового контроллера Вы могли перемещать указатель мыши. Вы можете создать различные программы (называемые стандартными настройками) для всех Ваших игр и при каждом запуске соответствующей игры автоматически устанавливать эти стандартные настройки!

Поскольку происходит постоянное улучшение драйверов, некоторая информация, содержащаяся в этой инструкции может незначительно не соответствовать самым последним версиям драйверов.

Эта он-лайновая инструкция по эксплуатации описывает программное обеспечение, разработанное для управления Вашим игровым контроллером. Некоторые части этой инструкции по эксплуатации могут не соответствовать точно тому, что Вы увидите на экране. Это связано с тем, что возможны отличия одного игрового контроллера Thrustmaster от другого, например, в количестве доступных для программирования кнопок или доступных осей. Некоторые скриншоты могут относиться к игровому контроллеру, который отличается от того контроллера, который Вы программируете в данный момент. Несмотря на это, базовые функции контроллеров будут преимущественно одинаковыми.

Программное обеспечение состоит из двух основных элементов:

Утилита панели задач

После окончания инсталляции программы в панели задач Windows появится иконка программы. Щелкните правой кнопкой мыши на этой иконке, чтобы перейти в панель инструментов Thrustmapper, которая содержит "горячие" кнопки для программы Thrustmapper и панели управления. Также Вы можете выбрать режим автоматической или ручной активизации стандартных настроек или отключить эту опцию совсем.

Утилита панели задач Thrustmapper содержит следующие опции:

Панель управления: Эта опция позволяет Вам напрямую перейти в диалоговое окно "Игровые устройства" Windows (в зависимости от операционной системы). Это диалоговое окно позволит Вам протестировать Ваш игровой контроллер и провести конфигурирование эффектов обратной связи.

Thrustmapper: эта опция запускает программу Thrustmapper, которая позволяет Вам настроить кнопки управления и оси Вашего игрового контроллера.

Автоматический: эта опция позволяет Вам автоматически активизировать различные стандартные настройки для каждой игры. Таким образом, стандартная настройка (группа параметров), предназначенная для определенной игры будет автоматически установлена после запуска соответствующей игры.

Ручной: эта опция позволяет Вам активизировать стандартную настройку, которая будет применена к каждой игре, которая уже запущена.

Отключить: эта опция позволяет Вам отключить все стандартные настройки. Это означает, что после запуска игры стандартные настройки не будут активизированы.

Закрыть: Эта опция закрывает утилиту панели задач.

О программе ...: Щелкните на О программе ..., чтобы перейти к диалоговому окну, содержащему информацию о версии Вашего программного обеспечения Thrustmapper.

Программа Thrustmapper

Программа Thrustmapper, основанная на стандартном интерфейсе Windows, предназначена для управления всеми расширенными функциями программирования, доступными для Вашего игрового контроллера.

Программа Thrustmapper состоит из:

  • стандартной панели меню/панели инструментов Windows для управления задачами,
  • браузера, расположенного с левой стороны и содержащего все доступные стандартные настройки параметров для различных программ,
  • панели настройки кнопок, которая позволяет Вам установить, настроить и запрограммировать все кнопки игрового контроллера на стандартные и расширенные функции,
  • панели настройки осей, которая позволяет Вам установить, настроить и запрограммировать все оси игрового контроллера на стандартные и расширенные функции,
  • тестовой панели. Эта панель содержит точно такую же информацию, что и тестовый интерфейс, встроенный в панель управления.

Пожалуйста, обратите внимание на то, что программа Thrustmapper доступна только для игровых контроллеров, которые подключены к одному из портов типа USB Вашего персонального компьютера. Если Ваше периферийное устройство снабжено смешанным разъемом для подключения к игровому порту/порту USB, программа будет недоступна для игрового порта. Программа Thrustmapper не поддерживает операционные системы Macintosh.

Thrustmaster является подразделением Guillemot Corporation.
© Copyright 2000-2001 Guillemot Corporation.


Меню

Интерфейс Thrustmapper включает в себя основное меню, состоящее из 4 подменю: Файл, Правка, Вид и Справка.

Меню Файл

Создать
[Ctrl]+[N]

Создает новую группу стандартных настроек. Открывает диалоговое окно Свойства стандартных настроек (требуется выбрать установленный игровой контроллер и тип игры. Также возможна связь настройки с игрой).

Открыть ...
[Ctrl]+[O]

Открывает диалоговое окно Открыть, позволяющее Вам получить доступ к папке PRESETS (СТАНДАРТНЫЕ НАСТРОЙКИ), в которой Вы можете открывать или искать файлы стандартных настроек. Впоследствии возможен импорт этих стандартных настроек в Thrustmapper, в котором Вы сможете выполнить редактирование и сохранение стандартных настроек.

Сохранить
[Ctrl]+[S]

Сохраняет текущие стандартные настройки (переписывая существующую версию). Если Вы закроете стандартные настройки, не сохранив последние изменения, на экране появится предупреждение. Если создаются новые стандартные настройки, на экране появится диалоговое окно Сохранить как . . . . По умолчанию будет предложена папка PRESETS (СТАНДАРТНЫЕ НАСТРОЙКИ).
Сохранить как ...

Сохраняет текущие стандартные настройки под новым названием. Открывает диалоговое окно Save As... (Сохранить как.... По умолчанию будет предложена папка PRESETS (СТАНДАРТНЫЕ НАСТРОЙКИ) .

Выход из программы Thrustmapper. Если Вы выйдете из программы, не сохранив последние изменения, на экране появится предупреждение. Если создаются новые стандартные настройки, на экране появится диалоговое окно Сохранить как ....

Выход

Меню редактирования Правка (доступно только через вкладку Кнопки)

Отменить | [Ctrl]+[Z] | Отмена последней выполненной операции.
Повторить | [Ctrl]+[Y] | Повтор последней отмененной операции.
Вырезать | [Ctrl]+[X] | Вырезать функцию, присвоенную кнопке (отображаемой в колонке Standard).
Копировать | [Ctrl]+[C] | Копировать функцию, присвоенную кнопке (отображаемой в колонке Standard).
Вставить | [Ctrl]+[V] | Вставить функцию, присвоенную кнопке (отображаемой в колонке Стандартная функция).

Меню Вид

Панель инструментов | Включение/выключение панели инструментов.
Панель состояния | Включение/выключение панели состояния в окне Thrustmapper.
Браузер стандартных настроек | Включение/выключение браузера стандартных настроек Preset. Если браузер не отображается, опция Файл/Открыть ... позволит Вам получить доступ к стандартным настройкам.
Стандартные/расширенные функции осей | Отображение режима конфигурирования осей (стандартного/расширенного). Эта опция активизируется только, если выбрана панель Оси.
Расширенные функции кнопок | Открывает окно Расширенные функции кнопок, которое позволяет Вам выбрать параметры программирования кнопок, которые Вы хотите отобразить во вкладке Кнопки. Эта опция активна только, если выбрана панель Кнопки.

Меню Справка

Содержание | Активизирует он-лайновую справку, которая снабдит Вас более подробной информацией об использовании программы.
Поиск | Позволяет Вам выполнить поиск по ключевому слову в файлах справки Thrustmapper.
Что это такое? | Активизирует контекстную справку Thrustmapper's. Щелкните на разделе справки, чтобы отобразить дополнительную информацию.
О программе ... | Открывает окно О программе ... (О программе), содержащее информацию о версии программы.


Панель инструментов

Панель инструментов Thrustmapper похож на стандартную панель инструментов Windows.

Создание новой стандартной настройки. Открывает диалоговое окно Свойства стандартных настроек (требуется выбрать установленный игровой контроллер и тип игры. Также возможна связь настройки с игрой).

Открывает диалоговое окно Открыть, позволяющее Вам получить доступ к папке PRESETS (СТАНДАРТНЫЕ НАСТРОЙКИ), в которой Вы можете открывать или искать файлы стандартных настроек. Впоследствии возможен импорт этих стандартных настроек в Thrustmapper, в котором Вы сможете выполнить редактирование и сохранение стандартных настроек.

Сохраняет текущие стандартные настройки (переписывая существующую версию). Если Вы закроете стандартные настройки, не сохранив последние изменения, на экране появится предупреждение. Если создаются новые стандартные настройки, на экране появится диалоговое окно Сохранить как .... По умолчанию будет предложена папка PRESETS (СТАНДАРТНЫЕ НАСТРОЙКИ).

Вырезать функцию, присвоенную кнопке (отображаемой в колонке Стандартная функция).

Копировать функцию, присвоенную кнопке (отображаемой в колонке Стандартная функция).

Вставить функцию, присвоенную кнопке (отображаемой в колонке Стандартная функция).

Удалить все функции и атрибуты, присвоенные выбранной кнопке (эта опция доступна только во вкладке Кнопки).

Переключение выбранной кнопки в кнопку SHIFT (эта опция доступа только в панели Кнопки).

Открывает окно О программе ..., содержащее информацию о версии программы.


Браузер стандартных настроек

Браузер стандартных настроек представляет собой систему архивирования, используемую программой Thrustmapper для управления доступными стандартными настройками, связанными с различными играми. В браузере будут отображаться стандартные настройки, связанные с уже проинсталлированными игровыми контроллерами.

Аналогично проводнику Windows браузер стандартных настроек позволяет Вам выполнять множество различных операций с файлами стандартных настроек - Копировать, Удалить, Переименовать. Кроме этого браузер стандартных настроек позволяет Вам определять стандартные настройки, которые будут активизироваться в автоматическом режиме, проверяя боксы, расположенные слева от этих стандартных настроек.

Стандартные настройки представляют собой общий набор параметров, предварительно установленных и сохраненных в памяти для определенных целей. Главным преимуществом возможности создания стандартных настроек для игровых контроллеров является фактор экономии времени. После однократной установки и тестирования нужных Вам значений параметров все, что Вам нужно будет сделать перед игрой - это просто выбрать стандартные настройки для применения установленных ранее значений параметров.

В браузере стандартные настройки классифицируются по программам, за которыми эти стандартные настройки закреплены. Незакрепленные ни за одной из программ стандартные настройки будут классифицированы в поле под названием Нет связанной программы.

Названия стандартных настроек, связанных с Вашим игровым контроллером отображаются в виде древа (tree). Чтобы открыть папку, щелкните левой кнопкой мыши на значке + слева. На экране будут отображены все стандартные настройки, соответствующие Вашему игровому контроллеру. Сбоку от названия каждых стандартных настроек будет отображен символ, представляющий тип игрового контроллера. (gamepad, джойстик, руль и т.д.).


Панель настройки кнопок

Панель Кнопки позволяет Вам запрограммировать кнопки игрового контроллера, что означает закрепление за каждой кнопкой определенной функции.

  • Колонка Кнопки содержит список кнопок и POV-направлений (8-сторонний pad или 8-сторонний наклонный переключатель), доступных на Вашем игровом контроллере. Кнопки в списке приведены в порядке возрастания номеров. POV-положения отображаются в виде стрелок направления внутри окружностей.

  • В колонке Стандартная функция отображается функция, присвоенная каждой кнопке. Существует возможность комбинирования трех типов эмуляции: эмуляция клавиатуры, представленная символами, заключенными в маленькие квадратики; эмуляция щелчков левой кнопки мыши, представленная символом мыши; эмуляция других кнопок, представленная кнопкой с вопросом (номер в окружности).

  • Колонка Комментарий позволяет Вам ввести описание функции, присвоенной соответствующей кнопке.
Три описанных выше колонки составляют нормальный режим программирования кнопок. Доступ к расширенному режиму может быть получен через опцию Расширенные функции кнопок в меню просмотра Вид, которое содержит различные параметры, которые могут быть применены к программируемым функциям.


Панель настройки осей

Панель Оси позволяет Вам запрограммировать оси Вашего игрового контроллера - другими словами, выполнить настройку их функций и чувствительность. Дисплей панели под вкладкой Оси зависит от типа и количества осей игрового контроллера.

На экране отображается фотографическое изображение Вашего игрового контроллера, показывающее настраиваемые оси контроллера. Каждый бокс содержит список доступных осей для каждой отдельной оси (Ось X, Ось Y, Ось Rz, Заслонка 0, Мышь X, Мышь Y).

Вы также можете настроить "мертвые" зоны осей. "Мертвые" зоны соответствуют диапазонам значений, для которых не эмулируется никаких действий.

Опция Инверсный режим позволяет Вам выбрать команду, противоположную команде, установленной для оси (например, если Вы выполните движение вправо, будет эмулирована команда перемещения влево).

Расширенный режим доступен через опцию Расширенные функции осей в меню просмотра Вид и поддерживает множество дополнительных параметров таких, как настройка границ. Функция настройки границ позволяет определить диапазон значений, устанавливая максимальный уровень значений и предотвращая уменьшение значений ниже определенного порога (значения).


Тестовая панель

Тестовая панель позволяет Вам просматривать кнопки и оси Вашего игрового контроллера (при тестировании кнопки/оси светятся/анимируются), а также функции, запрограммированные для кнопок в панели Кнопки.

Если выбранные стандартные настройки связаны с игровым контроллером, который не подключен, тестовая панель Thrustmapper будет недоступна и будет затенена серым цветом.

Подробное описание тестовой панели

Кнопки Вашего игрового контроллера и конфигурация POV графически представлены на тестовой панели. Вы можете протестировать кнопки, нажав на любую кнопку на игровом контроллере и увидев, что соответствующая кнопка начнет светиться на экране монитора.

Конфигурация осей Вашего игрового контроллера отображается на тестовой панели в графическом виде. Вы можете протестировать оси, переместив их на игровом контроллере. После перемещения осей Вы увидите, что графическое изображение на тестовой панели отобразит физический эффект движения (например, направление и перемещение оси). Оси некоторых игровых устройств будут представлены в виде анимированных векторов.

Сцена, представляемая в графическом симуляторе оси, будет зависеть от типа игры, определенной для текущих стандартных настроек. Симулятор будет демонстрировать эффект, создаваемый движением (например, увеличение покрытия земли при ускорении).

Щелчок левой кнопкой мыши на симуляторе позволяет переключаться между этим видом и стандартными указателями, отображающими уровень каждой оси.

Если на оси эмулируется мышь, уровень стандартных указателей будет нулевым (ось будет отключена).

Окно эмуляции отображает эмулируемые команды, а также стрелки (стрелка вниз - для нажатых кнопок, стрелка вверх - для отжатых кнопок). Это означает, что если Вы нажмете кнопку, которая была запрограммирована (эмуляция клавиатуры или мыши, назначение кнопок/POV), в окне эмуляции будет отображена соответствующая строка (экранное сообщение).


Панель управления

Панель управления позволяет протестировать Ваш игровой контроллер и настроить эффекты обратной связи. Для того, чтобы получить доступ к панели управления, щелкните правой кнопкой на иконке Thrustmapper в панели задач, а затем щелкните левой кнопкой на Панель управления. Затем щелкните на вкладке Свойства. На экране появится следующее окно.

Вкладка Тест

Функции тестирования аналогичны функциям тестовой панели Thrustmapper .

Вкладка Обратная связь

Эта вкладка доступна только для игровых контроллеров, снабженных функцией Обратная связь.

Во вкладке Обратная связь приведен список виброэффектов, которые могут быть использованы Вашим игровым контроллером. Для тестирования каждого эффекта щелкните на соответствующей экранной кнопке. Создается эффект, который будет применяться в игровом контроллере.

Указатели регулировки эффекта позволяют Вам настроить уровень эффектов обратной связи Вашего игрового контроллера.

Указатель Основной используется для регулировки общего уровня эффектов, а два других указателя - Динамический u Статический позволяют Вам регулировать соответствующие категории по отдельности, независимо от другого указателя.

Статические эффекты используются непосредственно программным обеспечением игры. Игра подсчитывает результирующую интенсивность текущих факторов, таких как скорость (одним из примеров является управление автомобилем на мощеной дороге).

Динамические эффекты создаются сигналами, независимо посылаемыми игровым контроллером; эти эффекты зависят от множества таких факторов, как ось, скорость и ускорение (дорожно-транспортное происшествие с повреждением автомобиля является наглядной иллюстрацией этих эффектов).

Указатель Возврат позволяет Вам отрегулировать мощность двигателя, которая возвращает игровой контроллер в его центральное положение. Для того, чтобы данная регулировка была применена ко всем играм, проверяйте бокс Всегда включено. Таким образом, даже если некоторые игры не поддерживают эффекты обратной связи, контроллер будет возвращаться в центральное положение автоматически в зависимости от интенсивности, определенной указателем.

Замечание: эта опция доступна только для определенных игровых контроллеров. Если опция не поддерживается Вашим контроллером, опция будет затенена серым цветом.

Бокс Эффекты оси Y применить к оси Х позволяет Вам применить эффекты обратной связи, первоначально запрограммированные для оси Y, к оси X. Эта опция предназначена для использования в играх, которые не оптимизированы для обработки эффектов обратной связи вдоль различных осей. Однако, подавляющее большинство игр в настоящее время позволяют управлять эффектами обратной связи по отношению к нескольким осям.

Замечание: эта опция доступна только для определенных игровых контроллеров. Если опция не поддерживается Вашим контроллером, опция будет затенена серым цветом.


Создание стандартных настроек

Перед выполнением любой операции Вы сначала должны создать стандартные настройки, которые Вы хотите использовать в играх. Для того, чтобы сделать это, в панели инструментов щелкните правой кнопкой мыши на иконке Thrustmapper, а затем щелкните на левой кнопкой мыши на строке Thrustmapper (или щелкните Пуск/Программы/Thrustmaster/Thrustmapper). На экране появится диалоговое окно Свойства стандартных настроек:

Бокс Устройство содержит список установленных и подключенных к компьютеру периферийных устройств. Выберите одно из устройств, для которого Вы хотите создать стандартные настройки.

Бокс Игровой профайл содержит различные типы игр (Авиационные симуляторы, Автомобильные симуляторы и т.д.), которые определяют создаваемые стандартные настройки. Выберите тип, соответствующий игре, для которой Вы создаете стандартные настройки.

Поле Запускаемый файл: является необязательным. Это поле позволяет связать стандартные настройки с определенной игрой. В этом случае, благодаря автоматическому режиму после запуска выбранной игры будут активизированы стандартные настройки, связанные с этой игрой. Чтобы определить маршрут для доступа к игре, щелкните левой кнопкой мыши на Обзор.. и выберите запускаемый (командный) файл игры. Если Вы не хотите связывать игру со стандартными настройками, Вы можете сделать это позднее с помощью Браузера стандартных настроек .

Поле Заголовок заполняется автоматически программой Thrustmapper, которая вносит в это поле название игры из списка в поле Запускаемый файл. Поле Заголовок может быть изменено только через браузер стандартных настроек.

После однократного ввода всей информации, щелкните левой кнопкой мыши на экранной кнопке OK, чтобы перейти к программе Thrustmapper, которая позволяет Вам запрограммировать оси и кнопки Вашего игрового контроллера.

Конфигурация кнопок в нормальном режиме

Содержание


Конфигурация кнопок в нормальном режиме

После создания стандартных настроек запустится программа Thrustmapper, чтобы Вы смогли настроить их.

Конфигурация кнопок

По умолчанию на экране будет отображаться панель Кнопки. Дважды щелкните левой кнопкой мыши на боксе Стандартная функция кнопки, которую Вы хотите запрограммировать. На экране появится диалоговое окно Стандартный редактор кнопок.

Активизирует/отключает одиночный режим. Активизация одиночного режима означает, что однократное нажатие (даже, если это нажатие будет продолжительным) на кнопку соответствует одной операции (нажатой кнопке, щелчку на кнопку мыши и т.д.). Например, если для кнопки 1 запрограммирована функция [A], удержание кнопки 1 в нажатом состоянии в течение 20 секунд приведет к эмуляции строки А, а не AAAAAAAAAAAAA...

Активизирует режим реального времени. Под активизацией режима реального времени подразумевается, что длительность нажатия на кнопку, а также интервал между каждым нажатием, записывается в реальном времени.

Активизирует режим фиксированного времени. В режиме фиксированного времени длительность нажатий на кнопки, а также интервал между каждым нажатием, фиксируются и соответствуют значению, выбранному в боксе (время приведено в миллисекундах). По умолчанию установлено время 100 мс.

Удаляет строку эмуляции. .

Добавляет щелчок мыши в строку эмуляции (щелчок на иконке с изображением кнопки соответствует эмулируемому щелчку).

Закрепляет кнопку или POV-направление за выбранной кнопкой. Вы также можете просто нажать на кнопку или POV-направление на Вашем игровом контроллере. Эта опция доступна только в одиночном режиме.

Перед вводом эмулируемой строки выберите режим конфигурации, который Вы хотите использовать (одиночный, режим реального или фиксированного времени). Эмулируемая строка состоит из последовательностей, которые объединяются в действия.
Последовательность представляет собой группу кнопок, нажатых одновременно.

Замечание 1: Режимы реального и фиксированного времени доступны только, когда выключен одиночный режим.

Замечание 2: В одиночном режиме эмулируемая строка состоит из одной операции (одного действия).

Затем щелкните на экранной кнопке OK. Эмулируемая строка появится в боксе Стандартная функция. Теперь, дважды щелкнув левой кнопкой мыши на боксе Комментарий, Вы можете ввести описание запрограммированной функции. Чтобы подтвердить ввод описания, нажмите [Enter].

Кнопка SHIFT

Вы можете удвоить количество программируемых функций Вашего игрового контроллера, определив одну из кнопок в качестве кнопки SHIFT. Новая функция теперь может эмулироваться одновременным нажатием на кнопку SHIFT и другую кнопку. В качестве кнопки SHIFT назначена только одна кнопка. Вы не можете ввести функцию в поле Стандартная функция кнопки SHIFT или ввести параметры в другие поля.

Чтобы запрограммировать вторую функцию кнопки, выберите кнопку, которую Вы назначите в качестве кнопки SHIFT, а затем щелкните левой кнопкой мыши на иконке Shift/Unshift [image] в панели инструментов Thrustmapper. В конце колонки Кнопки появится новый ряд кнопок. Процедура программирования этих кнопок аналогична: дважды щелкните левой кнопкой мыши на колонке Кнопки, чтобы перейти в стандартный редактор кнопок Стандартный редактор кнопок.

Конфигурация кнопок в расширенном режиме

Содержание


Конфигурация кнопок в расширенном режиме

Вкладка Кнопки также содержит расширенные параметры, относящиеся к запрограммированным кнопкам. В меню просмотра View щелкните на Расширенные функции кнопок, чтобы перейти к диалоговому окну Расширенные функции кнопок, которое позволит Вам выбрать параметры, которые Вы хотите отобразить.

Чтобы активизировать/отключать каждую опцию, проверяйте бокс с левой стороны от каждой опции, или для того, чтобы активизировать все опции, щелкните на Включить все (чтобы вернуться в нормальный режим, щелкните левой кнопкой мыши на Стереть все). Чтобы в режимах фиксированного и реального времени в боксе Стандартная функция отображать информацию о времени, проверяйте бокс Отображать рейтинг событий. Щелкните левой кнопкой мыши на OK.

Теперь вкладка Кнопки будет отображаться в расширенном режиме.

Замечание: Параметры в расширенном режиме недоступны для кнопок, запрограммированных в одиночном режиме (в диалоговом окне Стандартный редактор кнопок).

Для того, чтобы лучше понять функции различных параметров, давайте рассмотрим следующую эмулируемую строку:

[A];[A]+[AB]+[B]

Кнопки [A] и [B] нажаты на клавиатуре.

[ ] представляет одну операцию (одно действие), несколько знаков/букв внутри скобок являются частью одного действия.

+ связывает действия (операции) в одной последовательности.

; представляет собой окончание последовательности.

Все последовательности, объединенные вместе, формируют эмулируемую строку. Таким образом, для эмулируемой строки, описанной выше ([A];[A]+[AB]+[B]) будут выполнены следующие действия:

[A]: Нажмите кнопку А.

; означает, что Вы можете продолжить.

[A]: Нажмите кнопку А.

[AB]: Нажмите кнопку В (не отпуская кнопку A).

[B]: Отпустите кнопку A (не отпуская кнопку B).

Вы можете продолжить.

  • T (toggle). Включение опции T означает, что соответствующая кнопка (или POV-положение) будет посылать сигнал для последовательного выполнения каждой запрограммированной последовательности при каждом нажатии на кнопку.
    Чтобы активизировать/выключить опцию переключения toggle, щелкните на боксе T.

    Таким образом, для [A];[A]+[AB]+[B] мы получим:
    1 нажатие = [A]
    2 нажатие = [A]+[AB]+[B]

  • H (hold). Включение опции H означает, что после нажатия на соответствующую кнопку (или POV-положение), строка будет выполнена даже, если будет нажата другая кнопка - другими словами, две функции будут выполнены одновременно. Эта опция включена по умолчанию. Если эта опция отключена, строка не будет выполнена, если будет нажата другая кнопка.

  • Повтор. Значения в боксе Повтор соответствуют количеству повторов строки, каждого нажатия на кнопку или POV-положение. Чем выше число, тем больше количество повторов строки при каждом нажатии на кнопку.
    По умолчанию установлено значение Бесконечность. Дважды щелкните на боксе Повтор, чтобы ввести новое значение, а затем нажмите [Enter], чтобы подтвердить ввод. Чтобы вернуться к значению Бесконечность, в боксе Повтор введите значение 0.

    Таким образом, для 3-кратного повтора [A];[A]+[AB]+[B] мы получии:
    [A];[A]+[AB]+[B];[A];[A]+[AB]+[B];[A];[A]+[AB]+[B]

  • Группировка. Окно Группировка функционирует в прямой связи с окном повтора Повтор(см.выше). Если для одной кнопки или POV-положения запрограммированы несколько последовательностей, включение окна Группировка означает, что каждая последовательность будет повторена количество раз, указанное в окне Повтор. После повтора одной последовательности будет повторена следующая последовательность таким же образом.
    Щелкните на окне Группировка, чтобы включить или отключить опцию группировки.

    Таким образом, для 3-кратного повтора и группировки [A];[A]+[AB]+[B] мы получим:
    [A];[A];[A];[A]+[AB]+[B];[A]+[AB]+[B];[A]+[AB]+[B]

  • Скорость повтора. Значения в боксе Скорость повтора соответствуют интервалу между последовательно эмулируемыми строками для определенной кнопки или POV-положения. Чем выше значение, тем больше интервал между строками.
    По умолчанию устанавливается значение 0. Чтобы ввести новое значение, дважды щелкните левой кнопкой мыши на боксе Скорость повтора, а затем подтвердите ввод, нажав кнопку [Enter].     Чтобы вернуться к нулевой скорости повтора, в поле Скорость повтора установите нулевое значение 0.

Таким образом, при установленной скорости повтора 50 мс для [A];[A]+[AB]+[B] мы получим:
[A];[A]+[AB]+[B];(50)[A];[A]+[AB]+[B];(50)[A];[A]+[AB]+[B]

  • Вторая функция. Колонка Вторая функция отображает вторую функцию, присвоенную кнопке или POV-положению. Эта строка будет выполнена после нажатия и отпускания кнопки или POV-положения.

Окно эмуляции на тестовой панели позволяет Вам контролировать функции и параметры, применяемые к кнопкам игрового контроллера, т.к. оно отображает эмулируемые функции.

Конфигурация осей в нормальном режиме

Содержание


Конфигурация осей в нормальном режиме

Щелчок на вкладке Оси позволяет Вам изменить конфигурацию осей игрового контроллера. Отображаемая панель конфигурации осей будет зависеть от типа и количества осей игрового контроллера.

Чтобы присвоить оси определенную функцию, щелкните на одном из боксов. Ниже приведены варианты присвоений осей:

Ось Х: эмулирует движение вдоль горизонтальной оси.

Ось Y: эмулирует движение вдоль вертикальной оси.

Ось Rz: эмулирует руль направления (Rz соответствует вращению вокруг оси Z, являющейся осью глубины). Руль направления преимущественно используется в авиационных эмуляторах, а также в играх от первого лица (для выполнения функции "strafe").

Заслонка 0: эмулирует дросельную заслонку автомобиля (также называемую "slider").

Мышь X: эмулирует перемещение мыши вдоль горизонтальной оси.

Мышь Y: эмулирует движение мыши вдоль вертикальной оси.

Нет: Отключает ось.

Инверсный режим

После конфигурирования осей Вы можете включить опцию Инверсный режими установить команду, противоположную команде, установленной для оси (например, если Вы выполните движение вправо, будет эмулирована команда перемещения влево). Эта опция интересна преимущественно в авиационных симуляторах, в которых опция Инверсный режим может быть применена к оси Y для того, чтобы имитировать функцию штурвала управления летательным аппаратом.

"Мертвые" зоны

"Мертвые зоны" соответствуют диапазонам значений, в которых не эмулируются никакие операции. Таким образом возможно "игнорировать" тряску игрового контроллера, когда он находится в центральном положении, которое активно используется в играх. "Мертвые" зоны регулируются при помощи зеленых кривых. Отрегулируйте "мертвые" зоны, воспользовавшись функцией "drag and drop" мыши (курсор будет представлен в виде руки, когда Вы переместите его на одну из синих ручек). Активные значения представляются флюоресцентным зеленым цветом, а "мертвые" зоны - темно-зеленым цветом.

Для тестирования "мертвых" зон щелкните левой кнопкой мыши на симуляторе, чтобы показать стандартные шкалы, отображающие уровень каждой оси.

В примере, приведенном выше, в соответствии с конфигурацией "мертвой" зоны максимальное значение на оси Y будет достигнуто, когда стойка будет нажата только до половины.

Если в качестве игрового контроллера Вы используете руль, Вы можете включить опцию Объединить, чтобы объединить оси педалей, или опцию Разделить, чтобы использовать оси педалей по отдельности. Если включена опция Объединить, ускорение и торможение будут применяться к одной и той же оси, оси Y. Если включена опция Разделить, ось Y будет разделена на две оси, одна предназначена для ускорения, а другая - для торможения (третья ось - ось X). Количество доступных осей (2 или 3) зависит от игры. Преимущество трех осей заключается в том, что Вы можете ускоряться и тормозить одновременно, вызывая пробуксовку. При использовании только двух осей, одновременное ускорение и торможение не будут иметь эффекта: два значения будут взаимоисключать друг друга, т.к. они направлены вдоль одной оси, но в противоположные стороны.

Конфигурация осей в расширенном режиме

Содержание


Конфигурация осей в расширенном режиме

В меню просмотра Вид щелкните на вкладке Расширенные функции осей, чтобы переключиться в режим расширенной настройки осей контроллера, в котором Вы получите доступ к дополнительным опциям.

Режим Throttle

Режим Throttle появляется под каждой строкой выбора оси. Эта опция преобразовывает эффект давления, прилагаемого к стойкам. После проверки этой опции, если вы переместите стойку вдоль оси Х вправо, а затем вернете ее назад в центральное положение, движение вправо будет продолжено до тех пор, пока Вы не компенсируете это движение перемещением стойки влево вдоль оси Х. Основным преимуществом режима Throttle является возможность поддержания постоянного значения на выбранной оси, не прикасаясь к контроллеру. Эта опция преимущественно используется в режимах Throttle воздушных симуляторов.

Кривые

Кривые отображаемые в расширенном режиме представляют чувствительность оси. Щелчок на кривой позволяет перейти к следующему окну, в котором Вы можете настроить эту ось более точно.

Абсцисса (горизонтальная ось) представляет собой физическое движение (движение джойстика, POV или руля), а ось ординат (вертикальная ось) представляет собой передаваемый сигнал.

Два серых указателя позволяют Вам настроить мертвые зоны и выполняют функции зеленых указателей в режиме "Нормальные функции осей". Замечание: Если в нормальном режиме Вы уже определили мертвые зоны, эти зоны будут отображены в виде серой части кривой.

Благодаря функции "drag and drop" мыши , синий указатель позволяет Вам выполнить так называемую "настройку границ" - которая означает регулировку диапазона значений на оси. Уменьшение диапазона значений означает, что крайние значения исключаются. Настройка границ различается в зависимости от выбранной "мертвой" зоны, к которой применяется настройка границ (диапазона значений), тогда как "мертвые" зоны применяются к значениям, находящимся в различных точках оси.

Рассмотрим следующие примеры:

Пример 1: настройка границ | Пример 2: настройка "мертвой" зоны

В примере 1 уменьшение диапазона значений влияет только на передаваемый сигнал, но каждому положению на оси контроллера все еще будет соответствовать значение. В противоположность примеру 1, в примере 2 - после определения "мертвых" зон перемещение вдоль этой оси (после определенной точки) не будет оказывать влияния на интенсивность передаваемого сигнала.

Конечно, существует возможность объединения диапазона значений и "мертвых" зон для того, чтобы осуществлять одновременное управление передаваемым сигналом и перемещениями контроллера.

Благодаря функции "drag and drop" мыши, зеленый указатель позволяет Вам отрегулировать изменение сигнала в зависимости от давления, приложенного к оси. Таким образом, в примере, приведенном ниже, слабое давление на ось Y соответствует очень большому значению. В игровой ситуации такое нажатие вызовет резкое ускорение с незначительным движением вдоль оси Y.

Чтобы подтвердить установку параметров, щелкните на экранной кнопке ОК.

Сохранение стандартных настроек

Содержание


Сохранение стандартных настроек

После однократной конфигурации осей и кнопок, щелкните левой кнопкой мыши на Файл/Сохранить как ..., чтобы сохранить созданные стандартные настройки (или просто щелкните левой кнопкой мыши на иконку [image]). По умолчанию выбрана папка PRESETS. Настоятельно рекомендуем Вам сохранять стандартные настройки в папку PRESETS, т.к. стандартные настройки, сохраненные в других папках, будут недоступны в автоматическом и ручном режимах.

Использование стандартных настроек

Содержание


Использование стандартных настроек

Программа Thrustmapper может использоваться в автоматическом или ручном режимах, а также может быть отключена.

Автоматический режим

Чтобы активизировать автоматический режим, щелкните правой кнопкой мыши на иконке Thrustmapper в панели задач, а затем включите опцию Автоматический. Следующим шагом является выбор активизируемых стандартных настроек. Для того, чтобы сделать это, запустите программу Thrustmapper, а затем в браузере стандартных настроек щелчком левой кнопки мыши включите стандартные настройки, которые будут активизированы автоматически. Выйдите из программы. С этого момента после запуска программы, для которой были выбраны стандартные настройки, на экране появится сообщение, которое проинформирует Вас о том, что стандартные настройки применены к этой игре. Чтобы в автоматическом режиме отключить стандартные настройки, просто щелкните в квадратике слева от выбранных стандартных настроек в браузере стандартных настроек.

Замечание 1: Стандартные настройки, отображаемые в папке Нет связанной программы, не могут быть активизированы в автоматическом режиме.
Замечание 2: Запускаемый файл, предназначенный для выбранных стандартных настроек, должен существовать на диске, в противном случае в автоматическом режиме при следующем запуске Thrustmapper стандартные настройки будут отключены.

Чтобы обеспечить большую плавность анимации в играх, переключитесь в ручной режим и проверьте бокс Ускоренный режим. Для получения более подробной информации обратитесь к следующему разделу.

Ручной режим

Чтобы включить ручной режим, щелкните правой кнопкой мыши на иконке Thrustmapper в панели задач, а затем проверьте бокс Ручной режим. На экране появится окно Ручной режим.

Названия всех подключенных игровых контроллеров будут приведены в виде списка папок (контроллеры, которые были проинсталлированы, но в настоящий момент не подключены, не вносятся в этот список). Щелкните левой кнопкой мыши на символе + слева от названия контроллера, который Вы хотите использовать, а затем включите нужные Вам стандартные настройки, щелкнув на боксе слева. Для каждого контроллера Вы можете активизировать только одни стандартные настройки, поскольку эти стандартные настройки будут использоваться для каждой запущенной игры. После выполнения этой процедуры закройте окно Ручной режим.

Если Вы уже находитесь в ручном режиме и хотите выбрать другие стандартные настройки, в панели задач щелкните правой кнопкой мыши на иконке Thrustmapper, а затем проверьте бокс Ручной, чтобы отобразить окно Ручной режим.

Чтобы обеспечить большую плавность анимации в играх, включите опцию Ускоренный режим. Эта опция отключает предназначенные драйверы, тем самым разгружая процессор. Однако, некоторые игры, не поддерживающие эту опцию, могут реагировать на включение этой опции неправильно; в этом случае, Вы должны отключить опцию Ускоренный режим. По умолчанию опция Ускоренный режим выключена. Программа Thrustmapper сохраняет выполненные Вами настройки.

Отключить

Чтобы отключить программу Thrustmapper, щелкните правой кнопкой мыши на иконке Thrustmapper в панели задач, а затем включите опцию Отключено. Иконка Thrustmapper в панели задач изменит свой вид; с этого момента после запуска игр стандартные настройки не будут активизироваться.

Многопользовательский режим

Используя различные игровые контроллеры, Вы можете играть со своими друзьями на одном компьютере. Существует два способа сделать это:

В ручном режиме: Вы можете играть, используя несколько разных и даже одинаковых игровых контроллеров (если Вы выберете этот режим, Вы сможете связать все эти устройства с одними стандартными настройками или выбрать для каждого устройства определенные стандартные настройки).

В автоматическом режиме: Вы можете использовать несколько разных игровых контроллеров, поскольку за каждым игровым контроллером закреплены определенные стандартные настройки. Напротив, невозможно играть в автоматическом режиме, используя несколько одинаковых контроллеров.

Управление стандартными настройками

Содержание


Управление стандартными настройками

Импорт стандартных настроек

Для того, чтобы использовать стандартные настройки, полученные с других компьютеров или через Интернет, все, что Вы должны сделать - это скопировать стандартные настройки в папку Program Files\Thrustmaster\Thrustmapper\ Presets. Программа Thrustmapper автоматически обнаружит новые стандартные настройки и Вы сможете активизировать эти настройки в ручном или автоматическом режимах.

Работа со стандартными настройками

Браузер стандартных настроек программы Thrustmapper позволяет Вам управлять файлами стандартных настроек, аналогично проводнику Windows. Вы можете копировать, удалять, переименовывать и проверять различные опции стандартных настроек, просто щелкнув правой кнопкой мыши и выбрав соответствующую функцию.

Чтобы изменить маршрут (путь) к игре, связанной с выбранными стандартными настройками, в браузере стандартных настроек дважды щелкните на этих стандартных настройках. На экране появится диалоговое окно Свойства стандартных настроек. Щелкните на Обзор..., а затем выберите новый запускаемый файл. Чтобы подтвердить выбор, щелкните на экранной кнопке ОК.
Замечание: Если Вы измените связанную со стандартными настройками игру, стандартные настройки будут перемещены в папку, соответствующую выбранной Вами игре.

Чтобы изменить игровой маршрут для всех стандартных настроек в заданной папке, в браузере стандартных настроек дважды щелкните на этой папке. На экране появится диалоговое окно Свойства стандартных настроек. Щелкните на Обзор..., а затем выберите новый запускаемый файл. Чтобы подтвердить выбор, щелкните на экранной кнопке ОК.
Замечание: если Вы измените связанную игру, папка будет переименована в соответствии с вновь выбранным запускаемым файлом.

Чтобы изменить название папки, дважды щелкните на названии, которое Вы хотите изменить. На экране появится диалоговое окно Свойства стандартных настроек. В поле введите новое название Название, а затем щелкните на экранной кнопке OK.

Чтобы перейти в контекстное меню, щелкните правой кнопкой на одной из папок в Проводнике.

Показать все: показать все древо.
Отключить все: отключить древо, отображая только названия папок.
См.автомат.стандартные настройки: открывать только папки, содержащие стандартные настройки, настроенные для автоматического режима.
Свойства: позволяет Вам изменить игровой маршрут и название, связанное с папкой (Вы также можете выполнить эту процедуру, дважды щелкнув на папке).

Содержание


Thrustmaster

United Kingdom

Thrustmaster, Inc. c/o GUILLEMOT Ltd. - 3rd Floor, Central House - 27 Park Street - Croydon - SURREY - CR0 1YD - U.K.

(Open Monday to Friday from 10am to 5.30pm)

Tel: 020 7216 0047 Fax: +31-(0)30-6026279

E-mail: thrustmaster.uk@guillemotsupport.com

United States/Canada

Thrustmaster, Inc. c/o GUILLEMOT, Inc. - 5505, Bd Saint Laurent - Suite 4204 - Montreal, Quebec - H2T 1S6 - CANADA

(Open Monday to Friday from 8.30am to 7pm - Eastern Standard Time)

Tel: 1-877-484-5536 Fax: 1-514-490-0027

Web site: us.thrustmaster.com

France

Thrustmaster, Inc. c/o GUILLEMOT Service Après-Vente - Rue des Peupliers -
56910 Carentoir - FRANCE

(de 9h30 à 12h30 et de 13h30 à 19h30, du lundi au vendredi)

N&deg; Indigo : 0 825 85 78 10 (0,99 F TTC/mn) Fax : 02 99 08 96 45

E-mail : thrustmaster.fr@guillemotsupport.com

Deutschland/Österreich

Thrustmaster, Inc. c/o GUILLEMOT GmbH - techn. Hotline/Reklamation

(Montag bis Donnerstag 8:30 Uhr bis 17 Uhr, Freitag 8:30 Uhr bis 16 Uhr)

Tel: 01801 77 7775 Fax: 030/29666839

E-mail: thrustmaster.de@guillemotsupport.com

Belgique/Belgïe

Thrustmaster, Inc. c/o GUILLEMOT S.A. - Chaussée de Louvain 775 - 1140 Brussels - BELGIUM

(de 9h30 à 12h30 et de 14h00 à 18h00, du lundi au vendredi)
(van maandag t/m vrijdag van 9.30 tot 12.30 en van 14.00 tot 18.00)

Tel: 26394030 Fax: +31-(0)30-6026279

E-mail: thrustmaster.be@guillemotsupport.com

Italia

Thrustmaster, Inc. c/o GUILLEMOT S.r.l. - Viale Cassala, 22 - 20143 Milano - ITALIA

(Dal Lunedì al Venerdì dalle 14.30 alle 18.30)

Tel: 02 83 312 1 Fax: 02 83 312 300

E-mail: assistenza@guillemot.it

España/Portugal

Thrustmaster, Inc. c/o GUILLEMOT S.A. - Carretera de Rubi 72/74 Atico - Edificio Horizon - 08190 Sant Cugat del Vallès - Barcelona - ESPAÑA

(De lunes a viernes - Mañanas: de 09h a 13h30 - Tardes: de 15h a 18h30)

Tel: 935 90 69 60 Fax: +31-(0)30-6026279

E-mail: thrustmaster.es@guillemotsupport.com

Suisse/Schweiz

Thrustmaster, Inc. c/o LOGICOSOFTWARE SA - Avenue des Boveresses 46 - Case Postale 15 - 1000 Lausanne 21 - SUISSE

Tel: 022 5675120 (Suisse francophone); 07734-940873999 (deutschsprachige Schweiz)
Fax: +31-(0)30-6026279

E-mail: thrustmaster.ch@guillemotsupport.com

Scandinavia

Thrustmaster, Inc. c/o Guillemot Nordic A/S - Nordre Fasanvej 108, 1st floor - 2000 Frederiksberg - DANMARK

(open from 9am to 5pm every working day)

Tel: Denmark-82 33 28 58, Sweden-08 519 920 32, Norway-23 50 01 16,
Finland-09 817 101 54

E-mail: thrustmaster.wr@guillemotsupport.com

Nederland

Thrustmaster, Inc. c/o GUILLEMOT BV - Huizermaatweg 3A - 1273 NA Huizen - NEDERLAND

Technische support (maandag t/m vrijdag van 09.00 tot 18.00)

Tel: 0900 2026 765 / Fax: 030 6026279

E-mail: thrustmaster.nl@guillemotsupport.com

Australia

Thrustmaster, Inc. c/o GUILLEMOT Australia PTY Ltd - Level 3 - 111-117 Devonshire Street, Surry Hills, NSW 2010 - Sydney - AUSTRALIA

Technical support: 1902 262 514 (cost of call $1.65 per minute, higher for mobile/ public phone)

Tel: 61 2 8303 1818 / Fax: 61 2 9319 0422

E-mail: thrustmaster.au@guillemotsupport.com

Ceská republika

Thrustmaster, Inc. - Štefánikova 21 Praha 5 - Smíchov

Úrední hodiny: Od: 9:00 do 19:00

Tel.: 00420 2 / 51510018 / Fax: 00420 2 / 51512069

E-mail: info@guillemot.cz

For other countries, please visit http://europe.thrustmaster.com, click on Tech Support and choose Reach us.


Содержание

Описание программы | Использование программы
Описание программы - Меню - Панель инструментов - Браузер стандартных настроек - Панель настройки кнопок - Панель настройки осей - Тестовая панель - Панель управления | Создание стандартных настроек Конфигурация стандартных настроек - Конфигурация кнопок в нормальном режиме - Конфигурация кнопок в расширенном режиме - Конфигурация осей в нормальном режиме - Конфигурация осей в расширенном режиме Сохранение стандартных настроек Использование стандартных настроек Управление стандартными настройками


Техническая поддержка

Перед тем, как обратиться к нам, пожалуйста, подготовьте следующее:

  • Название устройства,
  • Дату покупки Вашего устройства,
  • Подробное описание конфигурации Вашего компьютера: тип процессора, память, операционная система,
  • Ручку и бумагу.

Пожалуйста, включите компьютер и найдите то место, в котором у Вас возникает проблема (или неисправность).

КОНТАКТЫ